import Foundation
let pattern = #"id \[([\d\w-]*)\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Error: GraphQL error: Fetch failure: HTTP 500 'Internal Server Error' for
https://localhost:3000: Unhandled command [https://localhost:3000.AddTag]
in [https://localhost:3000.AccountEntity]
with id [7f4cd122-4f1e-53bb-8501-68fc525bb1cd]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)