package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^&[^-]+-(?<pagination>\d+)&?$`)
var str = `&sot-4
&dorer-56&
&sot-281&
&dorer-0
sot-5
&dorer-
&sot-&
dorer-34&`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}