#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:\+|\d)[\d\-\(\) ]{9,}\d"
Local $sString = "вфыв ыфв фыв 8 900 000-00-00 вфыв ыфв фыв " & @CRLF & _
"" & @CRLF & _
"вфыв ыфв фыв +7 (900) 000 00-00 вфыв ыфв фыв " & @CRLF & _
"" & @CRLF & _
"вфыв ыфв фыв +7 9001112233 вфыв ыфв фыв " & @CRLF & _
"" & @CRLF & _
"вфыв ыфв фыв 89001112233 вфыв ыфв фыв " & @CRLF & _
"" & @CRLF & _
"вфыв ыфв фыв 8(900) 111-2233 вфыв ыфв фыв "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")