using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\+|\d)[\d\-\(\) ]{9,}\d";
string input = @"вфыв ыфв фыв 8 900 000-00-00 вфыв ыфв фыв
вфыв ыфв фыв +7 (900) 000 00-00 вфыв ыфв фыв
вфыв ыфв фыв +7 9001112233 вфыв ыфв фыв
вфыв ыфв фыв 89001112233 вфыв ыфв фыв
вфыв ыфв фыв 8(900) 111-2233 вфыв ыфв фыв ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}