use strict;
my $str = 'вфыв ыфв фыв 8 900 000-00-00 вфыв ыфв фыв
вфыв ыфв фыв +7 (900) 000 00-00 вфыв ыфв фыв
вфыв ыфв фыв +7 9001112233 вфыв ыфв фыв
вфыв ыфв фыв 89001112233 вфыв ыфв фыв
вфыв ыфв фыв 8(900) 111-2233 вфыв ыфв фыв ';
my $regex = qr/(?:\+|\d)[\d\-\(\) ]{9,}\d/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}