// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:\+|\d)[\d\-\(\) ]{9,}\d").unwrap();
let string = "вфыв ыфв фыв 8 900 000-00-00 вфыв ыфв фыв
вфыв ыфв фыв +7 (900) 000 00-00 вфыв ыфв фыв
вфыв ыфв фыв +7 9001112233 вфыв ыфв фыв
вфыв ыфв фыв 89001112233 вфыв ыфв фыв
вфыв ыфв фыв 8(900) 111-2233 вфыв ыфв фыв ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}