import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|[^\\w&+'])(?=[\\w&+']*\\w)\\K|\\G[\\w&+']*\\w[\\w&+']*\\K";
final String string = "This is a +sentence& &&with++ such words.\n"
+ "It doesn't treat + or &&&+++ as words.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}