import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![0-9]+$)(?=.*[a-zA-Z])[a-zA-Z0-9]+$";
final String string = "admin\n"
+ "l0v3y0oplj\n"
+ "123admin\n"
+ "123ADMIN?\n"
+ "123ADMIN\n"
+ "am.ouy?\n"
+ "12345678909776apouatgb\n"
+ "1ads967bjk\n"
+ "ADMIN123\n"
+ "123\n"
+ ",;/.;..,,;.#$¨$#¨%\n"
+ "!@#$%3333333333333333333332";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}