// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^-\n]+-([^-\n]+)").unwrap();
let string = "1234-ABC
1234-abc
1234-ABC-1a
1234
1234-abc-test-this";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}