$re = '/(?<=[\s,.:;"\']|^)l+o+l+(?=[\s,.:;"\']|$)/m';
$str = 'lool lol lllool';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);