import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\n][^\\S\\r\\n])[^\\S\\r\\n]+";
final String string = "<tr>\n"
+ " <td><strong>Vamos a sentarnos.</strong></td>\n"
+ " <td><strong>Let's sit down.</strong></td>\n"
+ "</tr>\n"
+ " <tr>\n"
+ " <td>veamos (ver)</td>\n"
+ " <td>let's see (to see)</td>\n"
+ "</tr>";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}