const regex = /([^\n][^\S\r\n])[^\S\r\n]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\n][^\\S\\r\\n])[^\\S\\r\\n]+', 'gm')
const str = `<tr>
<td><strong>Vamos a sentarnos.</strong></td>
<td><strong>Let's sit down.</strong></td>
</tr>
<tr>
<td>veamos (ver)</td>
<td>let's see (to see)</td>
</tr>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);