$re = '/^.*(Campaign A|Campaign B).*$/mi';
$str = 'In this block of text, our expression will only match a line if the expression contains either Campaign A or Campaign B.
This line will be filtered out.
This includes Campaign A
Campaign D
Campaign B
This is another random campaign we don\'t want
We want to include Campaign A and Campaign B
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);