// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)({".+)\)"#).unwrap();
let string = "<script>
Classify(\"cs.services/GlobalObject\").set(\"responseJson\",{\"DISPUTE_MESSAGE\":\"Test\",\"results\":[{\"resultText\":\"LALALA.\"},{\"resultText\":\"TEXT HERE\"},{\"resultText\":\"123\"}],\"STATUS\":\"OK\",\"REG\":\"Y\", \"Info\":{\"text\":\"123\",\"text2\":\"3\",\"image\":\"url\",\"id\":\"12345\"}});
Classify(\"cs.services/GlobalObject\").set(\"responseJson.LINK_URL\",\"/us/en/\");
Classify(\"cs.services/GlobalObject\").set(\"callerId\",\"ccweb\");
</script>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}