re = /(http(s)?:\/\/.)?(www\.)?[-a-zA-Z0-9:%._\+~#=]{2,256}\.[a-z]{2,6}\b([-a-zA-Z0-9%_:?\+.~#&\/=])*/
str = 'https://regex101.com/dhtdh/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end