use strict;
my $str = 'Created by David Carroll for Question on SoloLearn:
- https://www.sololearn.com/Discuss/1940608/?ref=app
- Also see: For List of TLD possibilities:
- https://regex101.com/r/9ugQHy/4
-----------------
Sample Data
-----------------
example@example.com
example@example.net
example@example.com
d.c-123@some-domain.uk.com';
my $regex = qr/^([\w-.]+)@([\w-]+)(\.[\w.-]+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}