$re = '/^([\w-.]+)@([\w-]+)(\.[\w.-]+)$/m';
$str = 'Created by David Carroll for Question on SoloLearn:
 - https://www.sololearn.com/Discuss/1940608/?ref=app
 - Also see: For List of TLD possibilities:
    - https://regex101.com/r/9ugQHy/4
-----------------
Sample Data
-----------------
example@example.com
example@example.net
example@example.com
d.c-123@some-domain.uk.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);