# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/function(\s*)\(((\S+,* *)*)\)(\s*){/($2) => {/g;t' <<< "function (param1, param2){
//
}
function (){
//
}
function() {
//
}
function (param1, param2){
//
}"