using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"function(\s*)\(((\S+,* *)*)\)(\s*){";
string substitution = @"($2) => {";
string input = @"function (param1, param2){
//
}
function (){
//
}
function() {
//
}
function (param1, param2){
//
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}