import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "function(\\s*)\\(((\\S+,* *)*)\\)(\\s*)\\{";
        final String string = "function (param1, param2){\n"
	 + "	//\n"
	 + "}\n"
	 + "function (){\n"
	 + "	//\n"
	 + "}\n"
	 + "function()	{\n"
	 + "	//\n"
	 + "}\n"
	 + "function					 (param1, param2){\n"
	 + "	//\n"
	 + "}";
        final String subst = "($2) => {";
        
        final Pattern pattern = Pattern.compile(regex);
        final Matcher matcher = pattern.matcher(string);
        
        // The substituted value will be contained in the result variable
        final String result = matcher.replaceAll(subst);
        
        System.out.println("Substitution result: " + result);
    }
}