# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"function(\s*)\(((\S+,* *)*)\)(\s*){"
test_str = ("function (param1, param2){\n"
" //\n"
"}\n"
"function (){\n"
" //\n"
"}\n"
"function() {\n"
" //\n"
"}\n"
"function (param1, param2){\n"
" //\n"
"}")
subst = "($2) => {"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.