$re = '/(\d{2}\.\d{2}\.\d{4})\s\|\s(\d{2}\:\d{2})/m';
$str = 'some text 07.09.2018 | 00:55';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);