re = /(\d{2}\.\d{2}\.\d{4})\s\|\s(\d{2}\:\d{2})/m
str = 'some text 07.09.2018 | 00:55'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end