$re = '/\/application(?!(\/something\/unwanted\/else))/m';
$str = '/application/something/else
/application/something/unwanted/else';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);