Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^([^;,\n]*)(;.*\b\1\b=|;.*;|;)([^;=,\n]+)(,.*|;)?$
/
gm
Input 1
1
New
# with k/v pairs declared http-metrics;http-metrics=/~/healthy; http-metrics;http-metrics=/~/read; http-metrics;http-metrics=/ping,http-service=/ping,proxy-test=/proxy http-service;http-metrics=/ping2,http-service=/ping http-service;http-metrics=/ping2,http-test=/ping http-metrics;;http-metrics=/~/healthy http-metrics;http-metrics=/~/read; http-metrics;;http-service=/ping http-metrics;;/ping http-metrics;/ping; ;;/~/healthy ;/~/healthy;