# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^;,\n]*)(;.*\b\1\b=|;.*;|;)([^;=,\n]+)(,.*|;)?$"
test_str = ("# with k/v pairs declared\n"
"http-metrics;http-metrics=/~/healthy;\n"
"http-metrics;http-metrics=/~/read;\n"
"http-metrics;http-metrics=/ping,http-service=/ping,proxy-test=/proxy\n"
"http-service;http-metrics=/ping2,http-service=/ping\n"
"http-service;http-metrics=/ping2,http-test=/ping\n"
"http-metrics;;http-metrics=/~/healthy\n"
"http-metrics;http-metrics=/~/read;\n"
"http-metrics;;http-service=/ping\n"
"http-metrics;;/ping\n"
"http-metrics;/ping;\n"
";;/~/healthy\n"
";/~/healthy;")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.