const regex = /__\?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('__\\?', 'g')
const str = `...TABLE __? (\`id\` int(11....`;
const subst = `list_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);