re = /\\\$/m
str = 'sd sewq wee r r ttttt $300 rrtrt utu iwiwi \\$500 kjgf ihj \\$215 ghi'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end