#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\*).+$|^.*[^\*]$|(?<=\*).+"
Local $sString = "*A" & @CRLF & _
"*A*" & @CRLF & _
"A*" & @CRLF & _
"*A*dffdg" & @CRLF & _
"kldf-sdf" & @CRLF & _
"sdfsdfdfg*" & @CRLF & _
"*dsfsdfgdsfg" & @CRLF & _
"fgdfgdfgdf*dfgdfg****************dfgdfg" & @CRLF & _
"fgdfgdfgdf*dfgdfg****************dfgdfg**" & @CRLF & _
"" & @CRLF & _
"****" & @CRLF & _
"*" & @CRLF & _
"" & @CRLF & _
"foo*barfoo" & @CRLF & _
"" & @CRLF & _
"*aa" & @CRLF & _
"aaa" & @CRLF & _
"aa*" & @CRLF & _
"" & @CRLF & _
"****" & @CRLF & _
"a**a" & @CRLF & _
"**a'" & @CRLF & _
"a***'" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")