package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`(?m)^(.*)\\.*$`)
    var str = `C:\\Users\\codep\\Desktop\\DM_HW2\\2017-07-9.csv`
    
    for i, match := range re.FindAllString(str, -1) {
        fmt.Println(match, "found at index", i)
    }
}