$re = '/^(.*)\\\\.*$/m';
$str = 'C:\\\\Users\\\\codep\\\\Desktop\\\\DM_HW2\\\\2017-07-9.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);