re = /^(.*)\\.*$/m
str = 'C:\\\\Users\\\\codep\\\\Desktop\\\\DM_HW2\\\\2017-07-9.csv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end