package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<img[^>]+>`)
var str = `String line = "<p class=MsoNormal align=center style='margin-bottom:0cm;margin-bottom:.0001pt;text-align:center;line-height:normal'><img width=165 height=128 src=image001.jpg/></p>"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}