const regex = /(?|(?<=null,)(.*?)(?=,null,(?:[0-9]{1,3})(?:,|$))|(?<=chara":|motion":)([^,\n]*))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?|(?<=null,)(.*?)(?=,null,(?:[0-9]{1,3})(?:,|$))|(?<=chara":|motion":)([^,\\n]*))', 'gm')
const str = `},null,"「奇跡? ……そ、そうだ! これは奇跡…… なら、この奇跡を利用しない手はないんじゃ!」","「奇跡? ……そ、そうだ! これは奇跡…… なら、この奇跡を利用しない手はないんじゃ!」"],["player",null,"「利用……?」",null,64,{
"data": [["bg","stage",{
"action": [["zpos",233.33333333333337]],
"class": "stage",
"name": "bg",
"redraw": {
"disp": 2,
"imageFile": {
"file": "bg03.mtn",
"options": {
"chara": "背景",
"motion": "昼"
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}