re = /\s?\+?\d{1,3}(\(|-|\s+)?\d+(\)|-|\s+)?(\d|-|\s)+\s?/
str = '+767 918 000-12-34'
# Print the match result
str.match(re) do |match|
puts match.to_s
end