import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+\\d{3}\\s?)?\\(?\\d{3}\\)?[\\s-]*\\d{2}[\\s-]*\\d{2}[\\s-]*\\d{2}$";
final String string = "+224 664 36 07 29\n"
+ "+224(664) 36 07 29\n"
+ "(664)36 07 29\n"
+ "+224664360729\n"
+ "664 36 07 29\n"
+ "664-36-07-29\n\n"
+ "66436\n"
+ "(664)\n"
+ "\\(?\\d{3}\\)?[\\s.-]\\d{3}[\\s.-]\\d{4}$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}