package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\.[0-9]{3}Z$`)
var str = `2017-11-06 11:27:57.443Z`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}