$re = '/\.[0-9]{3}Z$/';
$str = '2017-11-06 11:27:57.443Z';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);