$re = '/\b(?!(?:and|not|or)\b)\w+/u';
$str = 'This and This not That';
$subst = "\"$0\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;