Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?'type'[\w|\[\]\/]+)\s*\$(?'name'\w+)\s*(=\s*(?'default'[\w\'\\"]+)|)
/
gm
Test String
New
string $arg1='klk', $arg2 = 222, boolean $eee= false, $arg4, $arg5="fdsfds"