const regex = /^([^']*'[^']*)'/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^\']*\'[^\']*)\'', 'gi')
const str = ` ..Some.. '' `;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);