package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^:\s]+)*\s*:\s*([^;]+);`)
var str = `color: red;
bg: wat;
how : 'bout-that';`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}