#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?|([0-9]{1,2}h)[ ]*([0-9]{1,2}min)|([0-9]{1,2}h)()|()([0-9]{1,2}min)):\s*((?:.(?!(\dh\s\d{1,2}min|\dh|\d{1,2}min)))+)"
Local $sString = "1h 30min: Title " & @CRLF & _
"- Description Line 1" & @CRLF & _
"3h: SECOND TITLE" & @CRLF & _
"- Description Line 1" & @CRLF & _
"- Description Line 2" & @CRLF & _
"- Description Line 3" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"1h 14min: Title " & @CRLF & _
"- another Great one 42min: Title - Great Movie" & @CRLF & _
"- Description Line 2" & @CRLF & _
"- Description Line 3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")