#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\([^(]*ppm\b[^)]*\)"
Local $sString = "abc(cow) and def(pig 0.2ppmsheep)" & @CRLF & _
"abc(cow) and def(pig 0.2ppm sheep)" & @CRLF & _
"" & @CRLF & _
"Menthol(0.3ppm) Michale(36 years old man)" & @CRLF & _
"Michale(36 years old man) Menthol(0.3ppm)" & @CRLF & _
"Good(5%, 5,500ppm)" & @CRLF & _
"" & @CRLF & _
"abcd(333ppm) abcd(333ppm, 30%)" & @CRLF & _
"abcd1234(abc 333ppm)" & @CRLF & _
"abcd(333ppm, 30%) abcd(333ppm)" & @CRLF & _
"" & @CRLF & _
"abc(cow) and def(pig 0.2ppm sheep)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")