package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\([^(]*ppm\b[^)]*\)`)
var str = `abc(cow) and def(pig 0.2ppmsheep)
abc(cow) and def(pig 0.2ppm sheep)
Menthol(0.3ppm) Michale(36 years old man)
Michale(36 years old man) Menthol(0.3ppm)
Good(5%, 5,500ppm)
abcd(333ppm) abcd(333ppm, 30%)
abcd1234(abc 333ppm)
abcd(333ppm, 30%) abcd(333ppm)
abc(cow) and def(pig 0.2ppm sheep)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}