re = /\([^(]*ppm\b[^)]*\)/
str = 'abc(cow) and def(pig 0.2ppmsheep)
abc(cow) and def(pig 0.2ppm sheep)
Menthol(0.3ppm) Michale(36 years old man)
Michale(36 years old man) Menthol(0.3ppm)
Good(5%, 5,500ppm)
abcd(333ppm) abcd(333ppm, 30%)
abcd1234(abc 333ppm)
abcd(333ppm, 30%) abcd(333ppm)
abc(cow) and def(pig 0.2ppm sheep)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end