$re = '/^\d*[a-z][a-z\d]*$/mi';
$str = 'test123
1234
testtest
1ab2c3
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);