re = /^([0-1]?[0-9]|2[0-3]):[0|3][0]\s[A|P]M$/m
str = '9:00 AM
12:30 PM
3:30 PM
5:00 PM
12:30 PM
12:34 AM
3:21 PM
4:56 AM'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end