// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([0-1]?[0-9]|2[0-3]):[0|3][0]\s[A|P]M$").unwrap();
let string = "9:00 AM
12:30 PM
3:30 PM
5:00 PM
12:30 PM
12:34 AM
3:21 PM
4:56 AM";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}