// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)ref="[^"\r\n]*""#).unwrap();
let string = "[show_portfolio get=\"yachts\" for=\"sale\" in=\"europe\" sort=\"length_overall\" by=\"asc\" page=\"1\" perpage=\"18\" theme=\"active-71\" ref=\"http://replaceme.com\" debug=\"true\" engine=\"engine.com\"]
[get_portfolio get=\"yachts\" for=\"sale\" in=\"europe\" sort=\"length_overall\" by=\"asc\" page=\"1\" perpage=\"18\" theme=\"active-71\" ref=\"http://replaceme.com\" debug=\"true\" engine=\"engine.com\"]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}